Yellow Bullet Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6,563 Posts
Not a very common failure on those engines, is it eating coolant? Seems to me the last one I did on a 2V was an oil leak issue, but it was a long while ago.

They aren't awful to do, I personally for the time it takes like to pull the engine and do it on a stand, because I hate working over top of a fender.

Be careful with timing the camshafts, and put timing chain guides and tensioners in it while you have it apart.
 

·
Registered
Joined
·
6,563 Posts
Wait, I missed Super Duty, was thinking F150. There's a little more room to work in a SD over a 150, but personally I'd pull the motor, or in the case of a super duty, lift the cab.
 

·
Registered
Joined
·
1,076 Posts
Discussion Starter · #4 ·
It didnt seem to be eating coolant. It just happened out of no where. My Edge CTS never saw the temp go over 192. Every thousand miles it goes through a quart of oil but thats it. This is my first 5.4 so I dont know much about them.
 

·
Registered
Joined
·
1,076 Posts
Discussion Starter · #5 ·
It seems like its running out under the intake on the head. I am a little confused because there is no coolant in the water but when it blew I was accelerating and it fell on its face and it doesnt have much pep to it so i thought it fouled the plug out
 

·
Registered
Joined
·
2,933 Posts
Coolant crossover on the intake, common issue with the modular 2v. Have to replace the intake to fix it unless its already been done and has the aluminum unit. Then it might be just a gasket.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top