Yellow Bullet Forums banner

1 - 20 of 86 Posts

·
Security jus sayin crew
Joined
·
50,209 Posts
Discussion Starter #1
So my wife is driving the truck home and gets the traction control and service stability warming light. Told her to stop by advance auto and have then hook up the scanner to read the codes. They tell her they don't go out side after dark and they only check the computer if the engine light is on. So she goes home. I get home look at the truck, light still there. I checked the sensors to the abs, traction and stability. They are all connected but one won't stay clicked. I reset the computer. Hooked it all back up and still the same. Warning lights are still on.

Anyone have same issues? What u do?
 

·
Registered
Joined
·
4,177 Posts
We "had" a 02 Cadillac Seville that check engine light with traction control/ suspension stabilizer error code would come up. The code would come & go and GM couldn't fix it. After a few years of this and "many, many, many " electrical/ mechanical gremlins that could not be fixed.........we stopped driving the car (only 60,000 mi) for several months and sold it. Good luck!
 

·
Moderater
Joined
·
13,473 Posts
Go to the Dealer and tell them to reprogram the control modules...
 

·
Registered
Joined
·
4,517 Posts
might sound crazy but if the PCM sees a problem with any of the fuel system ie. evap,o2 or any fuel related sensor it will turn those lights on because they control the trac control with fuel. they are one trip codes and the PCM are sometimes two or three trip codes. get it scaned and know the truth about why they came on. GL
 

·
YB Monster Crew
Joined
·
9,107 Posts
Sounds like the ABS sensor in the hub bearing is going bad... Replace the whole thing...
 

·
Security jus sayin crew
Joined
·
50,209 Posts
Discussion Starter #8
I did wonder if it was a hub. Didn't hear anything roaring sounds or anything
 

·
Security jus sayin crew
Joined
·
50,209 Posts
Discussion Starter #9
might sound crazy but if the PCM sees a problem with any of the fuel system ie. evap,o2 or any fuel related sensor it will turn those lights on because they control the trac control with fuel. they are one trip codes and the PCM are sometimes two or three trip codes. get it scaned and know the truth about why they came on. GL
Thanks. Heading to auto zone tonight or tomm
 

·
Security jus sayin crew
Joined
·
50,209 Posts
Discussion Starter #11
Nothing feels wrong with the front shocks
 

·
Security jus sayin crew
Joined
·
50,209 Posts
Discussion Starter #13
Nothing seems wrong with the truck. Drives fine. But something is up since I am getting an error
 

·
Registered
Joined
·
16,880 Posts
my 04 denali did that everytime i started it. changed both front hubs and it went away
 

·
Registered
Joined
·
501 Posts
Could be a TPS sensor problem. Possibly p2135.
Or pedal position sensor code p2138.
 

·
Registered
Joined
·
866 Posts
Pull the codes first--if you dont you are simply shooting in the dark--and might change parts that dont need to be changed--i have changed several modules on Tahoes and they are not cheap---pull the codes!!
 

·
Message In Blood
Joined
·
2,025 Posts
I had the same issue on vacation with an 07 Tahoe. I had to clean the throttle body. It was a pedal position code. Cleaned it in the hotel parking lot and reset the codes and let pcm learn.
 
1 - 20 of 86 Posts
Top