Yellow Bullet Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
534 Posts
Discussion Starter #1
i have 05 duramax with heater issues.
when driving heater blows hot then cold gauges goes from 210 to 160 and starts blowing cold. upper radiator hose is cold also one side of the heater core is cold. ive changed out both t stats. used the bucket style filler with opening the bleeder on t sat housing after that system worked good while driving didnt over heat. blowing good heat out then i go to park it an let it sit for a couple of hours start it back up and it start all over again good heat then cold but it dont over heat . any ideas?
 

·
Registered
Joined
·
223 Posts
How many miles? Head gaskets?
 

·
Registered
Joined
·
534 Posts
Discussion Starter #6
222,000 i runs like a champ oil level staying the same system hold pressure 16 psi for hours. i back flushed heater core it work good till i parked it over night started it up did good for about 45 min then wham o cold all over again
 

·
Registered
Joined
·
534 Posts
Discussion Starter #8
after sitting for a while coolant level is on the half . i go to topp it off and open system it bubbles up to over flow then it reads full.
 

·
Registered
Joined
·
255 Posts
I want to say it has something to do with the dampener, like it is drawing outside air. My truck runs 160 and will run you out of the cab.
 

·
Registered
Joined
·
422 Posts
I want to say it has something to do with the dampener, like it is drawing outside air. My truck runs 160 and will run you out of the cab.
+1
Mine takes a long time to warm up, but with the grille cover on especially, it will get hotter than you can stand in the cab.

I would also check to see if heater control valve is operational, and concentrate more on the heater system/plenum
 
1 - 11 of 11 Posts
Top