WTF is going on - Yellow Bullet Forums
;

Go Back   Yellow Bullet Forums > Technical Section > Diesel Power

Reply
 
Thread Tools Display Modes
Old 10-21-2019, 11:27 AM   #1
chrisjk383
Junior Member
Spooled up
 
Join Date: Dec 2013
Posts: 219
Default WTF is going on

Hey guys,

I just finished replacing the head gaskets o my 6.5TD for my 1996 K3500... Along the way I did studs, gaskets, injectors, glow plugs etc... The truck is running now however there is an intermittent problem and I have been all over the 6.5 forums, but I figured it was time to try YB out... Every other day (roughly) I go out to start the truck, it takes a good 8 seconds to start, followed by a big puff of white smoke. The other days it starts right up. To add to that, if i start it once, it will start great for the rest of the day zero issues. Also, when it does run, it runs awesome! Before asking the inevitable: The glow plug system is working perfectly, all new grounds, and brand new raptor lift pump putting out 10PSI... Brand new crank sensor, brand new PMD, OPS filter removed... only other thing i can think of is an optical sensor itself, or the pump itself? I have been driving the truck with this issue for the last month, trying all the above things one step at a time with no success.

Any ideas are greatly appreciated!
chrisjk383 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-21-2019, 12:11 PM   #2
JRogers
Senior Member
Smoked another BBC
 
JRogers's Avatar
 
Join Date: Jan 2015
Posts: 1,805
Default Re: WTF is going on

cracked head
JRogers is offline   Reply With Quote
Old 10-21-2019, 02:25 PM   #3
chrisjk383
Junior Member
Spooled up
 
Join Date: Dec 2013
Posts: 219
Default Re: WTF is going on

Not saying its not possible, but the heads are brand new.
chrisjk383 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-21-2019, 04:27 PM   #4
Gdogg
Trump Voter NRA Member
Smoked Another SBC
 
Gdogg's Avatar
 
Join Date: Nov 2009
Location: S Lyon Mi
Posts: 5,229
Garage
Default Re: WTF is going on

A 6.5, you don't see many of those around.
So, typically your problem sounds like it sucking air or bleeding down overnight. When I get a truck that's bleeding down I just change every O-ring and rubber fuel hose on it, it's all old brittle rubber and that usually fixes it. So try that first.

The reason your probably getting the white smoke is because you cranked it for those 8 seconds, every revolution those injectors spray fuel, if it does burn that fuel (not start) the fuel goes in the exhaust, when it finally starts the fuel in the exhaust burns and creates the cloud of white smoke. White smoke = unburnt fuel, if the injectors are worn out and don't atomize the fuel like they should you will also get white smoke.
__________________
Give a man a fish and he'll eat for a day. Deport him, and you'll never feed him or his anchor babies ever again. Donald J Trump
https://onsizzle.com/i/donald-trump-...s-bible-224677
Gdogg is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 05:16 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 0%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Yellow Bullet LLC
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.