700r4 issues after engine swap - Yellow Bullet Forums
;

Go Back   Yellow Bullet Forums > Technical Section > Transmission - Hutch's Transmission Service

Transmission - Hutch's Transmission Service

Reply
 
Thread Tools Display Modes
Old 07-15-2019, 07:59 AM   #1
jakes84k10
Junior Member
Pre-Staged
 
jakes84k10's Avatar
 
Join Date: Nov 2017
Location: Mount Holly, NC
Posts: 88
Default 700r4 issues after engine swap

84 K10 with a 89-91 700r4, "corvette" stall converter so roughly 2000-2100 rpm. truck ran great and pulled great with the stock 350. Now i have a 383, Comp 276HR cam (224/230 @.050, .502/.510 lift) did not change anything, now the truck feels like something is binding and it has a rope attached to the bumper and holding it back. it doesnt want to shift out of first gear unless you let out of the as, otherwise itll just bounce off the limiter(i found out what my new engine sounds like at 6k). Has a constant pressure valve body. Transmission group on facebook suggested tv cable not adjusted as i had to replace it and the governer isnt set up for new engine. fluid isnt burnt, its nice and red. ANYONE have an idea? For what its worth i have 3.08 gears and a 32 inch tire, will be changing to 4.10s as funds come cause im a po boy.
__________________
Stock 07 Mustang GT auto/vert - daily driven
84 Chevy k10, built 700r4, 383 stroker, 1 3/4 headers, dual 3in exhaust(soon), work in progress
93 Wrangler, 4.0, 5 in lift, 33s, 8.8 swap, 4.10s, locked front and rear
jakes84k10 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-15-2019, 08:33 AM   #2
carpediem
Senior Member
Smoked another BBC
 
carpediem's Avatar
 
Join Date: Oct 2016
Location: ICT, KS, USA
Posts: 3,861
Default Re: 700r4 issues after engine swap

I agree with the TV cable out of adjustment. I am doing a 82 K5 and built a very similar 383 like u and has 35 x 12.5s. I'd try adjusting the TV and see how that works for you
carpediem is offline   Reply With Quote
Old 07-15-2019, 09:34 AM   #3
forcd02
Senior Member
Smoked Another SBC
 
forcd02's Avatar
 
Join Date: Jun 2005
Location: woodbine, md
Posts: 18,962
Default Re: 700r4 issues after engine swap

Since you changed the TV cable, that's what I would look at-was the old one 1 piece
and the new one 2 piece (adjustable?)
__________________
when your credit cards are max\'ed-call and raise the limits
forcd02 is offline   Reply With Quote
Old 07-15-2019, 10:03 AM   #4
jakes84k10
Junior Member
Pre-Staged
 
jakes84k10's Avatar
 
Join Date: Nov 2017
Location: Mount Holly, NC
Posts: 88
Default Re: 700r4 issues after engine swap

Quote:
Originally Posted by forcd02 View Post
Since you changed the TV cable, that's what I would look at-was the old one 1 piece
and the new one 2 piece (adjustable?)
not sure, it was a stock replacement from summit i believe. ill look back at my orders and see
__________________
Stock 07 Mustang GT auto/vert - daily driven
84 Chevy k10, built 700r4, 383 stroker, 1 3/4 headers, dual 3in exhaust(soon), work in progress
93 Wrangler, 4.0, 5 in lift, 33s, 8.8 swap, 4.10s, locked front and rear
jakes84k10 is offline   Reply With Quote
Old 07-15-2019, 10:11 AM   #5
jakes84k10
Junior Member
Pre-Staged
 
jakes84k10's Avatar
 
Join Date: Nov 2017
Location: Mount Holly, NC
Posts: 88
Default Re: 700r4 issues after engine swap

It was actually from O'Reillys
__________________
Stock 07 Mustang GT auto/vert - daily driven
84 Chevy k10, built 700r4, 383 stroker, 1 3/4 headers, dual 3in exhaust(soon), work in progress
93 Wrangler, 4.0, 5 in lift, 33s, 8.8 swap, 4.10s, locked front and rear
jakes84k10 is offline   Reply With Quote
Old 07-15-2019, 11:56 AM   #6
mufflerguy
Senior Member
Smoked Another SBC
 
mufflerguy's Avatar
 
Join Date: Jan 2006
Location: Windsor Ontario Canada
Posts: 15,708
Default Re: 700r4 issues after engine swap

************
__________________
Lets build a race car they said. It'll be fun they said. I don't know who "they" are.........but "they" need a good punch in the face!

Last edited by mufflerguy; 07-15-2019 at 11:57 AM.
mufflerguy is offline   Reply With Quote
Old 07-15-2019, 02:24 PM   #7
wesmigletz
Senior Member
Smoked another BBC
 
wesmigletz's Avatar
 
Join Date: Jan 2010
Location: North Texas
Posts: 1,095
Default Re: 700r4 issues after engine swap

Did you change carbs? Holley and Edelbrock have bolt on levers to maintain correct 70R4 geometry. That combined with an adjustable TV cable and correct cable bracket will fix what you’re describing
__________________
"Trying to win hearts and minds. Splattering them when necessary."
-US Army Cav Scouts

Pics www.picturetrail.com/wesmigletz
wesmigletz is offline   Reply With Quote
Old 07-15-2019, 10:29 PM   #8
Hutch
Transmission Specialist
Smoked Another SBC
 
Hutch's Avatar
 
Join Date: Mar 2005
Location: London Ontario Canada
Posts: 18,656
Default Re: 700r4 issues after engine swap

If it has a constant pressure vb then disconnect the cable and see if it shifts instantly. If so then you have to get it adjusted properly.


Hutch
__________________
www.hutchtrans.com
519-453-4318
Hutch is offline   Reply With Quote
Old 07-16-2019, 08:23 AM   #9
jakes84k10
Junior Member
Pre-Staged
 
jakes84k10's Avatar
 
Join Date: Nov 2017
Location: Mount Holly, NC
Posts: 88
Default Re: 700r4 issues after engine swap

Quote:
Originally Posted by wesmigletz View Post
Did you change carbs? Holley and Edelbrock have bolt on levers to maintain correct 70R4 geometry. That combined with an adjustable TV cable and correct cable bracket will fix what you’re describing
i went from a quickfuel 600 to a quickfuel 780. i made sure to get the holley linkages for it. have the holley stamped steel throttle and tv cable bracket.
__________________
Stock 07 Mustang GT auto/vert - daily driven
84 Chevy k10, built 700r4, 383 stroker, 1 3/4 headers, dual 3in exhaust(soon), work in progress
93 Wrangler, 4.0, 5 in lift, 33s, 8.8 swap, 4.10s, locked front and rear
jakes84k10 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-16-2019, 09:33 AM   #10
tnsmith10
Member
Pullin gears
 
tnsmith10's Avatar
 
Join Date: Jan 2009
Location: back in az
Posts: 539
Default Re: 700r4 issues after engine swap

by what you described, id say that the t.v. cable isnt set right like others mentioned. what i have found common is guys set the cable up like a th350 and if the 700 still has the fail safe ball, it will shift very late and firm. once you get the cable set right, it will probably shift soft and early and a governor recalibration kit would be a good idea. and also when you go to a shorter gear, the shifts will get even earlier and softer. gl
__________________
.060 350 sbc
ebay 200cc intake runner 64cc combustion chamber aluminum heads
howards hydraulic roller cam
700R4 with 3300-3700 stall lockup converter
4.10 gears
12.334 @ 108.58 best @ 4400 DA (yea, i know, still slow)
3280 lbs with me in it
tnsmith10 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 06:55 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 0%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Yellow Bullet LLC
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.