Need Help with a 2002 Chevy Blazer - Yellow Bullet Forums

Go Back   Yellow Bullet Forums > Fire your bullets!!! > Trash Or Be Trashed

Trash Or Be Trashed Where the weak are killed and eaten!!!! Vulgar language and nudity may be enclosed!! NWS

Reply
 
Thread Tools Display Modes
Old 01-06-2013, 11:24 PM   #1
gmracing355
Senior Member
Smoked another BBC
 
Join Date: Jun 2007
Location: New Jersey
Posts: 3,039
Default Need Help with a 2002 Chevy Blazer

Got a problem with my friend's Blazer, which has 140,000 miles on it. Came over running rough. It has codes: Multiple misfire code, lean bank 1 and 2 codes.

Checked and found out that intake gasket was leaking so we replaced the upper and lower intake gaskets. Truck still ran the same - very rough. We also changed the plugs, cap and rotor. Did a compression check while all the plugs were out and all cylinders were between 175 and 190. The car still runs very poor - no power. Had a spare, used spider regulator combo and placed that in, no changed to the problem, still runs rough. Put a fuel gauge on it, fuel pressure while running was between 55 and 60psi, but when you turn the key on and the pump primes the system, the gauge will go up to 60psi and suddenly drops down to 0 (did this with both the original spider and the replaced one). We also had another Blazer there and checked the fuel pressure on that and the gauge did not act the same way. The fuel pump is about a year old and the MAF sensor is new.

We couldn't set the timing because our computers did not go up to 2002, but before we pulled the distributor we marked the placement of everything.

Without a computer that goes up to 2002, we can't tell what is going on because the cards don't go up to that year..

Any ideas of what else we should consider would really be appreciated!

Thanks!

Greg
__________________
gmracing355 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-06-2013, 11:43 PM   #2
slammed1
Senior Member
Smoked another BBC
 
slammed1's Avatar
 
Join Date: Apr 2011
Location: Arkansas
Posts: 2,009
Default Re: Need Help with a 2002 Chevy Blazer

Fuel pumps can have good pressure but poor volume,which makes a poor running issue. Not a miss but very bad throttle response and power. The ignition modules can also cause poor running issues.

The hoses in the pump modules are notorious for splitting.
__________________
Brian M
1980 Camaro,1966 BelAir,2004 Dodge Ram HEMI on 42" tires,72 Chevy Short Wide project
2 door post website,check it out
http://twodoorpost.activeboard.com/

http://i886.photobucket.com/albums/a...mePhoto6-1.jpg
slammed1 is offline   Reply With Quote
Old 01-07-2013, 12:10 AM   #3
aazracing
Junior Member
Pre-Staged
 
Join Date: Jan 2010
Location: Billings,Montana
Posts: 66
Default Re: Need Help with a 2002 Chevy Blazer

Needs a fuel pump.
aazracing is offline   Reply With Quote
Old 01-07-2013, 12:57 AM   #4
Kyledvor61
Junior Member
Launchin
 
Kyledvor61's Avatar
 
Join Date: Jul 2011
Location: McHenry, IL
Posts: 358
Default Re: Need Help with a 2002 Chevy Blazer

My girlfriends does the same thing I think hers is 01 or 02. Did filter, plugs, wires, distrubutor cap and rotor and same thing. Off idle it falls on its ass and stumbles
Kyledvor61 is offline   Reply With Quote
Old 01-07-2013, 01:26 AM   #5
sg67nova
Senior Member
Smoked another BBC
 
sg67nova's Avatar
 
Join Date: Oct 2008
Location: Colorado
Posts: 1,644
Default Re: Need Help with a 2002 Chevy Blazer

Worn distributor gear?
Dirty Mass Air Flow sensor?
You should see a bad fuel pump on the gauge.
__________________
sg67nova is offline   Reply With Quote
Old 01-07-2013, 01:50 AM   #6
4Doors4Life
Junior Member
Spooled up
 
4Doors4Life's Avatar
 
Join Date: Nov 2008
Posts: 148
Default Re: Need Help with a 2002 Chevy Blazer

It should hold fuel pressure after the pump primes. Ive had a bad fuel pressure regulator leak into the back 2 cylinders. Leave the top half of the intake off reattach the fuel lines and let the pump prime and see where the fuel is going. That's how i figured out the problem. Hope this helps.
4Doors4Life is offline   Reply With Quote
Old 01-07-2013, 07:19 AM   #7
565bbccarbed
Member
Pullin gears
 
565bbccarbed's Avatar
 
Join Date: Jan 2010
Location: Oxford, Mi
Posts: 541
Default Re: Need Help with a 2002 Chevy Blazer

The fuel issue needs to be looked at , also fuel filter clogged will over pressure the pump and do what your describing . The main thing I have been changing on the "w" 4.3 votecs and the 96-99 vortec v8s is the whole distributor ,because the shaft gets out of round and wears the gear then finally gets erratic timing (which gives missfire mostly on #1 cylinder) .I have used this guy on ebay for my new aluminum housing distributors .Also have 6 out there that I have used 2 in my own vehicles (solves the mosture problem too) and one of mine has 20,000 miles on it still good .They do come with that locking hold down ,I grind them out so I can set my timing with a snap on computer , run in at -2 if you want better gas millage or +3 if you want more power of course 0 is perfect . check your coil too they get hot and flop in that holder makes a random missfire too . good luck . http://www.ebay.com/itm/96-05-Chevy-...3925f3&vxp=mtr
565bbccarbed is offline   Reply With Quote
Old 01-07-2013, 03:25 PM   #8
gmracing355
Senior Member
Smoked another BBC
 
Join Date: Jun 2007
Location: New Jersey
Posts: 3,039
Default Re: Need Help with a 2002 Chevy Blazer

Thanks guys for the sugestion on the problem. The fuel psi problem makes me also think about changing the fuel pump,it sucks cause it is not even a year old yet. The way it is running even at idle is like a plug wire or two is off. Shaking like crazy,lol I could not use my snap on scanner on it because the data cards only go to 1998. I will talk to the owner of it this week and see if hevfound anything else. Thanks guys.
Greg
__________________
gmracing355 is offline   Reply With Quote
Old 01-07-2013, 03:30 PM   #9
david068513
Go Fuck Yourself
Smoked Another SBC
 
david068513's Avatar
 
Join Date: Dec 2011
Location: north Ga
Posts: 6,441
Default Re: Need Help with a 2002 Chevy Blazer

It's the pump
Had the same issue three times. Was always the pump with my 2000. Don't get a cheap pump. I used a cheap one and it falled 3 times in a year.
__________________
1992 camaro z28-sbc gen 1 old school mullet ride
2014 ss camaro ls3 6 speed- weekend warrior
1998 Formula ls1

F-bodies everywhere. ..
david068513 is offline   Reply With Quote
Old 01-07-2013, 03:50 PM   #10
projoe87
Senior Member
Smoked Another SBC
 
Join Date: Mar 2008
Location: new jersey
Posts: 14,142
Default Re: Need Help with a 2002 Chevy Blazer

Id make sure you have Delco cap/rotor on that. If i remember correctly those used to crap out often.
projoe87 is online now   Reply With Quote
Old 01-07-2013, 03:51 PM   #11
bentwrench
left for better *****s
Smoked Another SBC
 
Join Date: Feb 2008
Location: state of insanity
Posts: 4,160
Default Re: Need Help with a 2002 Chevy Blazer

its the pump , I quit using the gearrotor styles as they have a issue of burning up if you run the fuel below a 1/3 tank and sucking air even with the buckets and also if the filters get plugged , I went to a bosch turbine style pump and no more comebacks ( would get comebacks on idiots who don't keep the tank more than 1/2 full ) , make sure you get the prefilter for them too , they are a ittle more work as you have to disassembe the bucket to install them but they work better ( and quieter too )
bentwrench is offline   Reply With Quote
Old 01-08-2013, 06:43 AM   #12
565bbccarbed
Member
Pullin gears
 
565bbccarbed's Avatar
 
Join Date: Jan 2010
Location: Oxford, Mi
Posts: 541
Default Re: Need Help with a 2002 Chevy Blazer

Hate to bring a new question into the mix ,but if your engine was burning some antifreeze threw the exhaust ( from the coolant leaking intake ) the bank 1 sensor 1 and the cat converter may be bad also .I use my snap on computer to look at the variances and flow rate of the o2 sensors to make sure they respond hot cold and after sitting for a few . The other thing I have changed that was doing the same as your description was the crank sensor when you buy it new comes with shims and a piece if material glued to the end of it for a adjustment .Sorry for the other possibilities - I know it can be endless
565bbccarbed is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 04:44 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Resources saved on this page: MySQL 2.94%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Yellow Bullet LLC