No boost - Yellow Bullet Forums

Go Back   Yellow Bullet Forums > Technical Section > Turbo Charged - Blitzkrieg Motorsports

Turbo Charged - Blitzkrieg Motorsports

Reply
 
Thread Tools Display Modes
Old 08-14-2013, 01:41 PM   #1
cam406406
Member
Pullin gears
 
Join Date: Feb 2007
Location: Lombard illinois
Posts: 695
Default No boost

Got new setup going
383 s400 with 88 wheel
It makes no boost
Did a air test found a pin hole in charge pipe fixed it
Sent turbo in to make sure it's ok checked out fine
Can the tune be so wrong it won't build any boost.
I did a fuw pulls with the car and got nothing but it ran good for a na car
Please help
cam406406 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-14-2013, 02:27 PM   #2
TurboII
Senior Member
Smoked another BBC
 
TurboII's Avatar
 
Join Date: Apr 2011
Location: Moncure, NC
Posts: 2,008
Garage
Default Re: No boost

Need more info on setup, engine management, timing, fueling, boost control??
TurboII is offline   Reply With Quote
Old 08-14-2013, 02:35 PM   #3
daniel6718
Member
Pullin gears
 
Join Date: Sep 2009
Posts: 638
Default Re: No boost

Bov hooked up wrong?
__________________
ProTree Racing
1994 z28...LF88/LS/Glide/9inch... 1.31 5.21@141 @35xx
1994 z28...N20/347 9.38@147.8 @3320
daniel6718 is offline   Reply With Quote
Old 08-14-2013, 03:33 PM   #4
tomato
Senior Member
Smoked Another SBC
 
Join Date: Mar 2009
Location: Fruit stand beyond thunder dome
Posts: 14,707
Default Re: No boost

Quote:
Originally Posted by daniel6718 View Post
Bov hooked up wrong?
Sounds backwards doesn't
tomato is offline   Reply With Quote
Old 08-14-2013, 03:37 PM   #5
Lil Boosty
Junior Member
Launchin
 
Lil Boosty's Avatar
 
Join Date: Jan 2009
Location: Chicagoland
Posts: 260
Default Re: No boost

check your wastegate it could be hooked up wrong also
__________________





HELL YEAH WERE TUNED BY KURGAN!!!
Lil Boosty is offline   Reply With Quote
Old 08-14-2013, 04:23 PM   #6
cam406406
Member
Pullin gears
 
Join Date: Feb 2007
Location: Lombard illinois
Posts: 695
Default Re: No boost

Wastegate right checked with shop air no blow off at the moment
Holley efi 160 injector
35 deg til it should make 6 lbs than pulling
8lbs spring in gate
cam406406 is offline   Reply With Quote
Old 08-14-2013, 04:33 PM   #7
cam406406
Member
Pullin gears
 
Join Date: Feb 2007
Location: Lombard illinois
Posts: 695
Default Re: No boost

On corn
cam406406 is offline   Reply With Quote
Old 08-14-2013, 05:07 PM   #8
TurboII
Senior Member
Smoked another BBC
 
TurboII's Avatar
 
Join Date: Apr 2011
Location: Moncure, NC
Posts: 2,008
Garage
Default Re: No boost

Verify MAP sensor with gauge if it doesn't have a boost gauge already.
TurboII is offline   Reply With Quote
Old 08-14-2013, 05:09 PM   #9
cam406406
Member
Pullin gears
 
Join Date: Feb 2007
Location: Lombard illinois
Posts: 695
Default Re: No boost

Did has vac and boost with air to it
cam406406 is offline   Reply With Quote
Old 08-14-2013, 05:57 PM   #10
tomato
Senior Member
Smoked Another SBC
 
Join Date: Mar 2009
Location: Fruit stand beyond thunder dome
Posts: 14,707
Default Re: No boost

Lines reversed on waste gate ?
tomato is offline   Reply With Quote
Old 08-14-2013, 06:47 PM   #11
Marty Staggs
Junior Member
Launchin
 
Marty Staggs's Avatar
 
Join Date: Aug 2008
Posts: 325
Default Re: No boost

Valve seat in the gate?
__________________
http://www.turbosmartusa.com/
Marty Staggs is offline   Reply With Quote
Old 08-14-2013, 06:50 PM   #12
Errol @ TPS
Senior Member
Smoked another BBC
 
Errol @ TPS's Avatar
 
Join Date: Apr 2009
Location: Work
Posts: 1,976
Default Re: No boost

That has never on the face of gods green earth happened.
Quote:
Originally Posted by Marty Staggs View Post
Valve seat in the gate?
__________________
Errol McCollum
Lube Tech
TPS
561 707 3395

Wastegates, BOV's and such

TPS Facebook page. Click like please.

If you really want to know who someone is, look at the people they are surrounded by.
Errol @ TPS is offline   Reply With Quote
Old 08-14-2013, 07:01 PM   #13
cam406406
Member
Pullin gears
 
Join Date: Feb 2007
Location: Lombard illinois
Posts: 695
Default Re: No boost

Yes all good
Valve in
fire ring in
Line from turbo to bottom of gate
Top of gate open
cam406406 is offline   Reply With Quote
Old 08-14-2013, 07:08 PM   #14
stockblock&23s
Junior Member
Launchin
 
Join Date: Aug 2011
Posts: 320
Default Re: No boost

Are there pistons in the motor..lol had to
stockblock&23s is offline   Reply With Quote
Old 08-14-2013, 07:54 PM   #15
cam406406
Member
Pullin gears
 
Join Date: Feb 2007
Location: Lombard illinois
Posts: 695
Default Re: No boost

Just got turbo back
Will see what happens if it don't build boost what could be going on
cam406406 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 02:52 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Resources saved on this page: MySQL 3.51%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Yellow Bullet LLC