Turbo 400 line presures/ Trans brake - Yellow Bullet Forums

Go Back   Yellow Bullet Forums > Technical Section > Transmission - Hutch's Transmission Service

Transmission - Hutch's Transmission Service

Reply
 
Thread Tools Display Modes
Old 10-05-2006, 09:41 PM   #1
1 fast purple nova
Junior Member
Burnout box
 
Join Date: Sep 2006
Posts: 4
Default Turbo 400 line presures/ Trans brake

I get maybe 30 passes out of a trans before I start burning clutches in the direct and intermediates. I have upgraded the intermediates to 4 frictions, and the direct to a 6 frictions with .065 clearance. Im thinking it's the pump not putting out enough presure. Any recomendations?.
Another question is my trans brake when applied let's the car roll forward about 2 inches before it engages. I have checked my spool valve it is free in the bore your help is appresiated.
1 fast purple nova is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-06-2006, 12:17 AM   #2
Hutch
Moderator
Smoked Another SBC
 
Hutch's Avatar
 
Join Date: Mar 2005
Location: London Ontario Canada
Posts: 13,714
Default

I need some details about the car first. weight, tire size, rear gear ratio, launch rpm, shift rpm ,finishline rpm.Best et and 60 ft.
How much line pressure do you have now, what type of transbrake do you use.


Let me know, Hutch
Hutch is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 10:10 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Resources saved on this page: MySQL 4.26%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Yellow Bullet LLC